source: TracEnFrancais/trac.spec @ 4

Last change on this file since 4 was 4, checked in by guillaume, 16 years ago
  • MAJ patch Trac 0.10.4
  • Ajout fichier spec PKG pour Fedora 7
File size: 8.1 KB
Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3# PKG
4%define _topdir %(echo $PKG_BUILD_ROOT)
5
6Name:           trac
7Version:        0.10.4
8Release:        1.6%{?dist}
9Summary:        Enhanced wiki and issue tracking system
10Group:          Applications/Internet
11License:        BSD
12URL:            http://trac.edgewall.com/
13Source0:        http://ftp.edgewall.com/pub/trac/%{name}-%{version}.tar.gz
14Source1:        trac.conf
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
16BuildArch:      noarch
17BuildRequires:  sed >= 3.95
18BuildRequires:  python-devel
19Requires:       python-clearsilver >= 0.9.3
20Requires:       subversion >= 1.1
21Requires:       httpd
22Requires:       python-sqlite
23
24Patch1:         trac-0.10.4-PKG.patch
25
26%description
27Trac is an integrated system for managing software projects, an
28enhanced wiki, a flexible web-based issue tracker, and an interface to
29the Subversion revision control system.  At the core of Trac lies an
30integrated wiki and issue/bug database. Using wiki markup, all objects
31managed by Trac can directly link to other issues/bug reports, code
32changesets, documentation and files.  Around the core lies other
33modules, providing additional features and tools to make software
34development more streamlined and effective.
35
36%prep
37%setup -q
38chmod -x contrib/*
39sed -i -e 's|/var/svn/test|/srv/svn|' trac/scripts/admin.py
40chmod -x htdocs/js/wikitoolbar.js
41sed -i -e 's/tracd 1/tracd 8/' scripts/tracd.1
42rm trac/test.py
43sed -i -e 's/\r//' contrib/trac-post-commit-hook.cmd
44%patch1 -p1
45
46%build
47%{__python} setup.py build
48
49%install
50rm -rf $RPM_BUILD_ROOT
51
52# --skip-build causes bad stuff in siteconfig.py as of 0.8.4
53%{__python} setup.py install -O1 --root $RPM_BUILD_ROOT
54
55install -dm 755 $RPM_BUILD_ROOT%{_var}/www/cgi-bin
56mv $RPM_BUILD_ROOT%{_datadir}/trac/cgi-bin/trac.*cgi \
57  $RPM_BUILD_ROOT%{_var}/www/cgi-bin
58rm -r $RPM_BUILD_ROOT%{_datadir}/trac/cgi-bin
59
60install -Dpm 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/httpd/conf.d/trac.conf
61install -dm 755 $RPM_BUILD_ROOT%{_sbindir}
62mv $RPM_BUILD_ROOT{%{_bindir}/tracd,%{_sbindir}/tracd}
63install -dm 755 $RPM_BUILD_ROOT%{_mandir}/man8
64mv $RPM_BUILD_ROOT%{_mandir}/{man1/tracd.1,man8/tracd.8}
65
66%clean
67rm -rf $RPM_BUILD_ROOT
68
69%files
70%defattr(-,root,root,-)
71%doc AUTHORS ChangeLog COPYING INSTALL README* RELEASE THANKS UPGRADE contrib/
72%{_bindir}/trac-admin
73%{_sbindir}/tracd
74%dir %{python_sitelib}/trac/
75%{python_sitelib}/trac/*.py
76%{python_sitelib}/trac/*.pyc
77%{python_sitelib}/trac/*.pyo
78%dir %{python_sitelib}/trac/mimeview/
79%{python_sitelib}/trac/mimeview/*.py
80%{python_sitelib}/trac/mimeview/*.pyc
81%{python_sitelib}/trac/mimeview/*.pyo
82%dir %{python_sitelib}/trac/scripts/
83%{python_sitelib}/trac/scripts/*.py
84%{python_sitelib}/trac/scripts/*.pyc
85%{python_sitelib}/trac/scripts/*.pyo
86%dir %{python_sitelib}/trac/ticket/
87%{python_sitelib}/trac/ticket/*.py
88%{python_sitelib}/trac/ticket/*.pyc
89%{python_sitelib}/trac/ticket/*.pyo
90%dir %{python_sitelib}/trac/upgrades/
91%{python_sitelib}/trac/upgrades/*.py
92%{python_sitelib}/trac/upgrades/*.pyc
93%{python_sitelib}/trac/upgrades/*.pyo
94%dir %{python_sitelib}/trac/versioncontrol/
95%{python_sitelib}/trac/versioncontrol/*.py
96%{python_sitelib}/trac/versioncontrol/*.pyc
97%{python_sitelib}/trac/versioncontrol/*.pyo
98%dir %{python_sitelib}/trac/versioncontrol/web_ui/
99%{python_sitelib}/trac/versioncontrol/web_ui/*.py
100%{python_sitelib}/trac/versioncontrol/web_ui/*.pyc
101%{python_sitelib}/trac/versioncontrol/web_ui/*.pyo
102%dir %{python_sitelib}/trac/web/
103%{python_sitelib}/trac/web/*.py
104%{python_sitelib}/trac/web/*.pyc
105%{python_sitelib}/trac/web/*.pyo
106%dir %{python_sitelib}/trac/wiki/
107%{python_sitelib}/trac/wiki/*.py
108%{python_sitelib}/trac/wiki/*.pyc
109%{python_sitelib}/trac/wiki/*.pyo
110%dir %{python_sitelib}/trac/db
111%{python_sitelib}/trac/db/*.py
112%{python_sitelib}/trac/db/*.pyc
113%{python_sitelib}/trac/db/*.pyo
114%dir %{python_sitelib}/trac/util
115%{python_sitelib}/trac/util/*.py
116%{python_sitelib}/trac/util/*.pyc
117%{python_sitelib}/trac/util/*.pyo
118
119%config(noreplace) /etc/httpd/conf.d/trac.conf
120%{_datadir}/trac/
121%{_var}/www/cgi-bin/trac.cgi
122%{_var}/www/cgi-bin/trac.fcgi
123%{_mandir}/man1/trac-admin.1*
124%{_mandir}/man8/tracd.8*
125
126%changelog
127* Tue Sep 04 2007 Guillaume Bougard <gbougard@pkg.fr> - 0.10.4-1.4
128- minor fixes
129
130* Tue Aug 21 2007 Guillaume Bougard <gbougard@pkg.fr> - 0.10.4.1-1
131- Francisation
132- Ajout de fonctions utilisées par PKG.fr
133- resynchronisation avec la tracduction officielle
134
135* Thu May  3 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.10.4-1
136- Update to 0.10.4
137
138* Mon Mar 12 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.10.3.1-2
139- Switch requires back to python-sqlite
140
141* Sat Mar 10 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.10.3.1-1
142- Update to 0.10.3.1 to fix security bug
143
144* Sun Jan  7 2007 Joost Soeterbroek <joost.soeterbroek@gmail.com> - 0.10.3-2
145- change req: python-sqlite -> python-sqlite2
146
147* Tue Jan  2 2007 Joost Soeterbroek <joost.soeterbroek@gmail.com> - 0.10.3
148- upstream release 0.10.3 (#221162)
149
150* Sat Dec  9 2006 Joost Soeterbroek <joost.soeterbroek@gmail.com> - 0.10.3
151- rebuild for python 2.5, add python-devel to BR
152
153* Tue Nov 28 2006 Joost Soeterbroek <joost.soeterbroek@gmail.com> - 0.10.2
154- upstream release 0.10.2 (#217539)
155
156* Sat Nov 11 2006 Joost Soeterbroek <joost.soeterbroek@gmail.com> - 0.10.1
157- upstream release 0.10.1 (fixes CSRF vulnerability, bugzilla #215077)
158
159* Thu Sep 28 2006 Joost Soeterbroek <fedora@soeterbroek.com> - 0.10
160- upstream release 0.10 'Zengia'
161
162* Wed Aug 30 2006 Joost Soeterbroek <fedora@soeterbroek.com> - 0.9.6-3
163- remove %%ghost for .pyo files; bugzilla #205439
164
165* Wed Aug 30 2006 Joost Soeterbroek <fedora@soeterbroek.com> - 0.9.6-2
166- rebuild for Fedora Extras 6
167
168* Thu Jul  6 2006 Joost Soeterbroek <fedora@soeterbroek.com> - 0.9.6-1
169- upstream release 0.9.6
170
171* Tue Apr 18 2006 Joost Soeterbroek <fedora@soeterbroek.com> - 0.9.5-1
172- bug fix release 0.9.5
173
174* Wed Feb 15 2006 Joost Soeterbroek <fedora@soeterbroek.com> - 0.9.4-1
175- 0.9.4
176 * Deletion of reports has been fixed.
177 * Various encoding issues with the timeline RSS feed have been fixed.
178 * Fixed a memory leak when syncing with the repository.
179 * Milestones in the roadmap are now ordered more intelligently.
180 * Fixed bugs:
181   1064, 1150, 2006, 2253, 2324, 2330, 2408, 2430, 2431, 2459, 2544,
182   2459, 2481, 2485, 2536, 2544, 2553, 2580, 2583, 2606, 2613, 2621,
183   2664, 2666, 2680, 2706, 2707, 2735
184
185* Mon Feb 13 2006 Joost Soeterbroek <fedora@soeterbroek.com> - 0.9.3-5
186- Rebuild for Fedora Extras 5
187
188* Mon Jan 16 2006 Joost Soeterbroek <fedora@soeterbroek.com> - 0.9.3-4
189- updated trac.conf to allow for trac.*cgi
190
191* Mon Jan 16 2006 Joost Soeterbroek <fedora@soeterbroek.com> - 0.9.3-3
192- re-added tracd and trac.fcgi by user request.
193
194* Tue Jan 10 2006 Joost Soeterbroek <fedora@soeterbroek.com> - 0.9.3-2
195- removed trac.fcgi (bugzilla #174546, comment #11)
196- applied patch (bugzilla #174546, attachment id=123008)
197
198* Mon Jan  9 2006 Joost Soeterbroek <fedora@soeterbroek.com> - 0.9.3-1
199- 0.9.3
200- removed tracd (bugzilla #174546, comment #6)
201- added trac.conf for httpd
202- removed %%{python_sitelib}/trac/test.py
203- removed comments
204
205* Tue Dec  6 2005 Joost Soeterbroek <fedora@soeterbroek.com> - 0.9.2-2
206- added /etc/init.d/tracd
207- added /etc/sysconfig/tracd
208
209* Tue Dec  6 2005 Joost Soeterbroek <fedora@soeterbroek.com> - 0.9.2-1
210- 0.9.2
211- fixes SQL Injection Vulnerability in ticket search module.
212- fixes broken ticket email notifications.
213
214* Sat Dec  3 2005 Joost Soeterbroek <fedora@soeterbroek.com> - 0.9.1-1
215- 0.9.1
216- fixes SQL Injection Vulnerability
217
218* Tue Nov 29 2005 Joost Soeterbroek <fedora@soeterbroek.com> - 0.9-1
219- Rebuild for Fedora Extras
220
221* Tue Nov  1 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.9-1
222- 0.9.
223
224* Mon Jun 20 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.8.4-0.1
225- 0.8.4.
226- Move tracd to %%{_sbindir} and man page to section 8.
227
228* Thu Jun 16 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.8.3-0.1
229- 0.8.3.
230
231* Wed Jun  1 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.8.2-0.1
232- 0.8.2.
233
234* Sun May 29 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.8.1-0.2
235- Rebuild for FC4.
236
237* Fri Apr  8 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.8.1-0.1
238- First build.
Note: See TracBrowser for help on using the repository browser.